Scheduled for March 26, 2026 at 12:30 PM – 1:53 PM
Affects
Public Cloud
Under maintenance from 12:30 PM to 1:53 PM
Updates
Completed
March 26, 2026 at 1:53 PM
Completed
March 26, 2026 at 1:53 PM
Maintenance has completed successfully.
In progress
March 26, 2026 at 12:30 PM
In progress
March 26, 2026 at 12:30 PM
Maintenance is now in progress
Planned
March 26, 2026 at 12:30 PM
Planned
March 26, 2026 at 12:30 PM
We would like to inform you that we will be performing maintenance on our Public Cloud - hypervisor in Dallas, Texas.
Please note that during this maintenance window, we do not expect any downtime or service interruptions. Our team will work diligently to minimize any potential impact on your operations. This maintenance only affects customers with services in Dallas, Texas.
We apologize for any inconvenience this may cause and appreciate your understanding as we continue to improve the reliability and performance of our systems.